Note! Shortcuts may vary according to language.

General Keyboard Shortcuts

Shortcut Menu Action
Alt+F File Change to file menu page
Ctrl+N File > New Create a new file
Ctrl+O File > Open Open an existing file.
Ctrl+S File > Save Save the active file.
Ctrl+Alt+S File > Save as Save the active file with a new name.
Shift+Ctrl+S File > Save all Save all files.
Ctrl+F4 File > Close Close the active file.
Shift+Ctrl+F4 File > Close all other Close all other pages.
Ctrl+P File > Print Print the active file.
Alt+B File > View in browser View current file in default browser.
Alt+F4, Esc File > Exit Quit the application.
Alt+E Edit Change to edit menu page
Alt+S Search Change to file search page
Shift+Ctrl+F Search > Find in files Search for a string in multiple files
Alt+V View Change to view menu page
Ctrl+Alt+D View > Directory > Open Open a new directory.
Shift+Ctrl+E View > Directory > Edit Edit active directory.
Shift+Alt+X View > Directory > Close Close active directory.
Ctrl+F12 View > Files Search files from the selected directory and its subdirectories.
Shift+Ctrl+J View > Sync edit Show or hide synchronized editing.
Ctrl+H View > Hex editor Show or hide the hex editor
Shift+Ctrl+Tab View > Previous page Go to previous page
Ctrl+Tab View > Next page Go to next page
Alt+T Tools Change to file tools page
Shift+Ctrl+M Tools > Macro > Stop Stop the macro recording.
Shift+Ctrl+P Tools > Macro > Playback Playback the macro.
Shift+Ctrl+R Tools > Macro > Pause Pause a macro.
Shift+Ctrl+R Tools > Macro > Record Record a macro.
Ctrl+Esc Tools > Magnifier > Close Close magnifier
Alt+H Help Change to help menu page
Ctrl+F1 Help > Shortcuts Show keyboard shortcuts
Alt+F9   Open title bar encoding menu
Alt+F10   Open title bar highlighter menu
Alt+F11   Open title bar color theme menu
Alt+F12   Open title bar file list
F5 Directory Refresh files
F11   Fullscreen

Editor Keyboard Shortcuts

Shortcut Menu Action
Down   Moves down one line.
Ctrl+Down   Scrolls down one line.
Shift+Down   Moves down one line with selection.
Up   Moves up one line.
Ctrl+Up   Scrolls up one line.
Shift+Up   Moves up one line with selection.
Right   Moves the cursor one character to the right.
Ctrl+Right   Moves the cursor one word to the right.
Shift+Right   Moves the cursor one character to the right with selection.
Left   Moves the cursor one character to the left.
Ctrl+Left   Moves the cursor one word to the left.
Shift+Left   Moves the cursor one character to the left with selection.
Spacebar   Inserts a space.
Ctrl+Spacebar   Displays the Code Completion pop-up window.
Tab   Inserts a tab.
Shift+Tab   Moves the cursor to the left one tab position.
End   Moves to the end of the current line.
Enter   Inserts the carriage return.
Ins   Toggles between the insert and overwrite modes.
Backspace   Deletes a character to the left of the cursor.
Ctrl+Backspace   Deletes the word to the left of the cursor.
Shift+Backspace   Deletes the character to the left of the cursor.
Del   Deletes a character to the right of the cursor.
Home   Moves the cursor position to the start of the current line.
Shift+Home   Selects from the cursor position to the start of the current line.
Alt   Toggle between line and column selection mode.
Page Down   Moves down one page.
Ctrl+Page Down   Moves to the bottom of a screen.
Shift+Ctrl+Page Down   Selects from the cursor position to the bottom of the screen.
Page Up   Moves up one page.
Ctrl+Page Up   Moves to the top of a screen.
Shift+Ctrl+Page Up   Selects from the cursor position to the top of the screen.
Ctrl+D   Add to favourites.
Ctrl+Z Edit > Undo Undo the last action.
Shift+Ctrl+Z Edit > Redo Redo the previously undone action.
Ctrl+X Edit > Cut Cut the selection and put it on the clipboard.
Ctrl+C Edit > Copy Copy the selection and put it on the clipboard.
Ctrl+Alt+C Edit > Copy with line numbers Copy the selection and put it on the clipboard.
Ctrl+V Edit > Paste Paste clipboard contents.
Ctrl+A Edit > Select all Select all.
Shift+Ctrl+U Edit > Move > Decrease Decrease indent.
Shift+Ctrl+I Edit > Move > Increase Increase indent.
Shift+Alt+D Edit > Insert > Date and time Insert date and time.
Shift+Ctrl+G Edit > Insert > GUID Insert GUID.
Shift+Alt+C Edit > Insert > Hex color Insert hex color.
Ctrl+T Edit > Insert > HTML/XML tags… Insert HTML/XML tags.
Ctrl+Enter Edit > Insert > Line Insert line.
Ctrl+Y Edit > Delete > Line Delete line.
Shift+Ctrl+Y Edit > Delete > End of line Delete end of line.
Ctrl+W Edit > Delete > Word Delete word.
Ctrl+BkSp Edit > Delete > Word Delete word backward.
Ctrl+Del Edit > Delete > Word Delete word forward.
Shift+Ctrl+U Edit > Move > Decrease Decrease indent.
Shift+Ctrl+I Edit > Move > Increase Increase indent.
Shift+Ctrl+Down Edit > Move > Line down Move line down.
Shift+Ctrl+Up Edit > Move > Line up Move line up.
Shift+Alt+Up Edit > Move > Selection up Move selection up.
Shift+Alt+Down Edit > Move > Selection down Move selection down.
Shift+Alt+Left Edit > Move > Selection left Move selection left.
Shift+Alt+Right Edit > Move > Selection right Move selection right.
Shift+Ctrl+C Edit > Toggle case Toggle case.
Ctrl+U Edit > Toggle case > Upper Toggle upper case.
Ctrl+L Edit > Toggle case > Lower Toggle lower case.
Shift+Ctrl+A Edit > Sort > Ascending Sort ascending.
Shift+Ctrl+D Edit > Sort > Descending Sort descending.
Ctrl+F2 Search > Toggle bookmarks > Toggle bookmark Set unnumbered, or clear, bookmark at current line.
Ctrl+Shift+1..9 Search > Toggle bookmarks > Bookmark 1..9 Set numbered, or clear, bookmark at current line.
F2 Search > Go to bookmarks > Next Go to next bookmark.
Shift+F2 Search > Go to bookmarks > Previous Go to previous bookmark.
Ctrl+1..9 Search > Go to bookmarks > Bookmark 1..9 Go to numbered bookmark.
Ctrl+G Search > Go to line Go to line.
Ctrl+F Search > Search… Search the specified text.
F3   Find the next matching text.
Shift+F3   Find the previous matching text.
Alt+Enter   Find all matching texts.
Ctrl+R Search > Replace… Replace the specified text with different text.
F6 Search > Spell check Toggle spell check.
Ctrl+F6 Search > Next error Find the next spell check error.
Ctrl+Shift+F6 Search > Previous error Find the previous spell check error.
Alt+Down View > Folding > Next Move to next folding.
Alt+Up View > Folding > Previous Move to previous folding.
Alt+Left View > Folding > Collapse line Collapse line.
Alt+Right View > Folding > Expand line Expand line.
Ctrl+-, Ctrl+Num-   Editor zoom out.
Ctrl++, Ctrl+Num+   Editor zoom in.